Web Compliance Statement

Home / Local Governments / E-Pay / Web Compliance Statement

To comply with current Payment Card Industry Data Security Standards, the E-Pay e-commerce application currently supports the following browsers:

  • Internet Explorer 11 (Internet Explorer 10 can be used, but may require changes to your browser settings)
  • Google Chrome v.38 or greater
  • Mozilla Firefox v.27 or greater
  • Safari v.7 or greater